Updates from the Repl.it team about the product

← Back to all posts
Experiencing difficulties
amasad (2448)

Hey everyone, we're experiencing some infrastructure difficulties. Specifically around loading repls. You might still be able to load your repl.

Earlier this morning we had a huge surge in traffic that caused a cascade of issues we're trying to debug. We're unsure if the traffic surge is legit or caused by a DDoS. Please bear with us.

Edit: All systems are go! Thanks for your patience.

Thanks,

Repl.it Team

Commentshotnewtop
Foster_Bryant (97)

There is no point in DDoSing repl.it..It's an educational site.

RogueHalo (402)

@Foster_Bryant Hackers don't care tbh, they tend to just pick targets at random, I can't imagine anyone would have any hate against repl.it.

mat1 (3284)

@Foster_Bryant There's plenty of reasons to ddos Repl.it. For example: competition sites or services, spam creating repls that mine cryptocurrency, kids that don't want to have to use Repl.it at school, etc

Grify (167)

@mat1 why wouldn't kids want repl.it at school

especially the type that can DDoS, they should be all in for coding with repl.it

[deleted]

It doesn’t really matter. They can still spam you on google using this. They make the server go crazy, log into your account, steal your email address, and spam you. @Foster_Bryant

JamesGordon1 (114)

@mat1 wait you can mine bitcoins on here?!

Zexogon (905)

Thanks amasad! I wish you all the best man! Hopefully not a DDoS, I know you guys will have it solved soon :3

JamesGordon1 (114)

um u guys just broke python and im pissed off

amasad (2448)

@JamesGordon1 sorry about that. Will have someone take a look

masfrost (110)

@JamesGordon1 Hey James. We just looked into. We did not break Python, it seems like you wrote 200 megabytes to user.py programatically and that broke your repl. Try using the history to restore it.

Also please be more respectful when reporting problems, I deleted the swear word you wrote.

JamesGordon1 (114)

@masfrost wait how, i have ran it before with no problems, idk sorry i was just upset last night. sorry

masfrost (110)

@JamesGordon1 I understand. Don't worry about it, just keep in mind that we try to keep this place friendly and empty of negativity.

Looking at the file diff, this seems to be the culprit

JamesGordon1 (114)

@masfrost umm i didn't write that?!?!

JamesGordon1 (114)

@masfrost i wasn't even awake when that was made

enigma_dev (7079)

if you didnt do that, change your password to your repl.it account. probaply someone figured it out. @JamesGordon1

JamesGordon1 (114)

@enigma_dev quick question do u keep a log of when people log in to an acount

enigma_dev (7079)

good question, i dont think so @JamesGordon1

MATHyou (30)

It seems that most issues have been solved, but Pygame still isn't running properly. I know you'll have it fixed soon! Thanks for the explanation!

Uzalii (437)

Nice explanation and very helpful thanks

AtriDey (106)

Thanks! Not sure if it's my school WiFi or the traffic surge, but it takes 10 minutes for repls to load (timed). Good luck fixing it!

rajco (1)

is this this the reason for not getting output for the code

JoeyLent (18)

@rajco Yes, this is the reason why.

Grify (167)

Postmortem, what happened?

masfrost (110)

@Grify Running a postmortem tomorrow, will share as much as possible

rediar (309)

@masfrost didn’t find out anything?

Grify (167)

@rediar @masfrost so much for sharing as much as possible /:

JamesGordon1 (114)

pygame still isn't back online yet, why?
fork/exec /usr/local/bin/python3: no such file or directory

Haaruun (95)

Thanks for the explanation, thought my computer was glitching out.

LiamDonohue (283)

thanks! i was having problems too