3
CNAME records, CloudFlare, Freenom, and disappointment
JohnDoe29 (2)

First of all, I set up a Freenom domain (free domain, if you want to know). I used CloudFlare to set up the CNAME records, and the target was the custom domain Repl.it allows you to set.

But then, a plot twist happened: It wasn't reading the record. I've set it up perfectly with no errors. My disappointment is immeasurable and my day is ruined.

You are viewing a single comment. View All
1
themaka (176)

Hi @JohnDoe29 -- man using Freenom and CloudFlare is painful.

Ok, I've just set up the following using free domains and cloudflare.

https://python.maka.gq/
https://bubbles.maka.cf/
https://bubbles.maka.gq/

As far as I can tell, the issue seems to be Freenom. I set up domains and then Cloudflare just didn't find them, forever ...

Here's what I did:

To Freenom:
Create domain -- choose to forward the URL to repl.it (you'll change it later)

To Cloudflare:
Use Add Site -- enter new domain there. Hope it works. The first domain took one try, the second domain took 15 or so tries.

To Repl:
Use the edit option to setup the custom domain. Copy the CNAME record data that ends in repl.co so that you can go back

To Cloudflare:
Select CNAME from the dropdown menu, enter the domain (with subdomain if you wish) into the first field and paste the *.repl.co address into the second field. You can click the orange button to prevent traffic from going to Cloudflare.

To Repl:
... it should now say "You're all set" and you can just click Link. But, on one occasion, I had to reload the web page, then re-set it up, and it worked.

1
JohnDoe29 (2)

@themaka Nope, still not working.