Ask coding questions

← Back to all posts
Cannot install flask
MoonlightCtl (0)

Whenever I try to install the flask package, this happens:

Repl.it: Updating package configuration

--> /usr/local/bin/python3 -m poetry add Flask
Using version ^1.1 for Flask

Updating dependencies
Resolving dependencies...

[SolverProblemError]
The current project must support the following Python versions: *
Because no versions of flask match >1.1,<1.1.1 || >1.1.1,<2.0
 and flask (1.1.0) requires Python >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*
, !=3.4.*, flask is forbidden.
So, because flask (1.1.1) requires Python >=2.7, !=3.0.*, !=3.1.*,!=3.2.*,
!=3.3.*, !=3.4.*
 and root depends on Flask (^1.1), version solving failed.

add [-D|--dev] [--git GIT] [--path PATH] [-E|--extras EXTRAS] [--optional] [--python PYTHON] [--platform PLATFORM] [--allow-prereleases] [--dry-run] [--] <name> (<name>)...

exit status 1


Repl.it: Package operation failed.

What's happening? I cannot run my app without this package.