Issue Importing from Github
Jackleonard1 (1)

I receive a "the String did not match the expected pattern" when trying to import from Github, however I'm following the exact pattern specified by repl.it

Here's a few things to help troubleshoot:

  • my repo is set to public
  • my repo URL works perfectly fine anywhere else
  • I haven't had this issue before
  • I've tried, to no success:
https://github.com/user/repo
http://github.com/user/repo
https://www.github.com/user/repo
github.com/user/repo
You are viewing a single comment. View All
MMarkosPro21 (1)

Add the https:// then add the link :)

Vandesm14 (704)

@Jackleonard1 Nope. Is your repo private? If so make it public then try. If it still doesn't work, dm me on Discord and I can set up your repl manually (Vandesm14#3364)

Jackleonard1 (1)

@Vandesm14 Hi, No it is set to public. I don't use Discord I'm afraid.

Vandesm14 (704)

@Jackleonard1 I guess the only thing that's left to do is for you to report this to https://repl.it/bugs

Jackleonard1 (1)

@Vandesm14
Thanks for the tip ! I've just sent through a bug report. This is a pretty bad bug to have in production, disappointed in the repl.it team. Could have been easily mitigated with some basic qa.

Vandesm14 (704)

@Jackleonard1 Its sad.
Here's the command I was talking about:

git init && git remote add origin link-to-your-repo && git fetch --all && git reset --hard origin/master

Create a repl. Then, hit F1, type in "shell", hit enter, copy+paste the command, and hit enter. Your repo should now be imported into the repl!

Please mark this as answered if I helped your problem 👍

Jackleonard1 (1)

@Vandesm14 This is awesome! Going to try out now. Thanks so much !

Jackleonard1 (1)

@Vandesm14

Should this happen? - Unsure how to hit F1 using Mac OS X, so just popped it in the console

Vandesm14 (704)

@Jackleonard1 Try this one:
git init && git clone link-to-your-repo && git fetch --all && git reset --hard origin/master
If that doesn't work try this:
git init && git clone link-to-your-repo