Ask coding questions

← Back to all posts
Package Installation Failure. Must be doing something wrong...
elisobylak (1)

New to repl.it
Trying to add package (https://github.com/rominf/profanity-filter#installation) i have 'profanity-filter==1.1.12' in my requirements.txt file but I get a error that reads,

"Installing collected packages: spacy, tomlkit, poetry-version, profanity-filter

Repl.it: package installation failed!"

What am I missing? I've installed other packages in repl.it with no problem.

Certainly there must be an explanation for the difficulty I'm experiencing.

link to repl.it: https://repl.it/repls/ClumsyQuestionableGlobalarrays

Thanks

Answered by TheDrone7 (551) [earned 5 cycles]
View Answer
Commentshotnewtop
TheDrone7 (551)

As far as I could see, spacy is not a pip package and thus cannot be installed by naming it in your requirements file. And I don't know if there is another way for it.
Also, the link you provided to your repl was invalid.

elisobylak (1)

@TheDrone7 Understood. That must be it then cuz everything else works great.
Here is the link again, maybe? If it doesn't work, I think I've gotten the information I needed. Thanks!
https://repl.it/@elisobylak/ClumsyQuestionableGlobalarrays

TheDrone7 (551)

@elisobylak the link you provided this time was right. The usual link to repls is https://repl.it/@<username>/<replname>. For future references.