Ask coding questions

← Back to all posts
Problems with Pygame + Replit on Chromebooks
mvidberg (0)

Hi! My students are attempting to do some simple animations in Pygame using Replit. They are using Chromebooks to do this, which may or may not be relevant. They are running into frequent "Bash" errors. Is this a known problem?

Commentshotnewtop
eankeen (679)

Hmm. Does the game still run? I saw one of the screenshots you posted below, and I've seen those messages appear on my PyGame repls. However, for me, the game screen still pops up. Refreshing the page or forking the repl might make the error message disappear. I would post a bug report if you can't get it to work :)

mvidberg (0)

@eankeen Here is a link to a sample Pygame Replit file from one of my students. It gives the error I posted earlier, but then it doesn't display any output. When I try it on my laptop the output does appear, but when he does it on his computer (Windows 10 machine using Chrome) there is no output, even if he waits several minutes. Here is the link: https://repl.it/@DanielDoucette/PyGameFunctions1py

eankeen (679)

@mvidberg Hmm. That's sort of weird. Yeah I was able to get it to work fine. The only thing that I think could be causing this is the age of your browser. Maybe it hasn't been updated in a while? I really wish I could help you more, but haven't run into these types of problems before.

IzanLarumbe (28)

Maybe they are your students that don't know how to code in pygame or that they are using python 2.7 instead of 3.x

MATTHEWBECHTEL (122)

Yeah your gonna have to give us some more information to let us help you... like archie here said, can you give us a link to the code or tell us what errors are occurring?
Upvote this comment if it’s useful, or you just simply just want to Upvote it.

mvidberg (0)

@MATTHEWBECHTEL Here is a screenshot of the error:

MATTHEWBECHTEL (122)

Yeah, that isn’t specifically an error... can you show me the link? @mvidberg I can try to figure out what is wrong.

ArchieMaclean (619)

@mvidberg That happens with all pygame repls and is not an actual error. The code should still run fine even with that. Was there anything wrong apart from that?

A link to the repl would be good.

MATTHEWBECHTEL (122)

Why did you reply to my comment lol.
@ArchieMaclean

ArchieMaclean (619)

Can you give us the whole error? And the code?

The chromebooks are not a problem, I use a chromebook too.
If they are trying to do this within a classroom, then I don't think it works (unless you make a new classroom of type Pygame which you may be able to do? I am not a teacher so I don't know).