Ask coding questions

← Back to all posts
[Resolved] Console Frozen
h
JBYT27 (1150)

Hello!

I attached the following repl, but the console seems to be frozen. I click run, but it does nothing. What is going on? Please help, I would appreciate it!

Answered by Bookie0 (4977) [earned 5 cycles]
View Answer
Commentshotnewtop
Bookie0 (4977)

ah wait maybe it's beause nothing is happening, in this repl you only declared lists and variables, and a few conditionals, but you don't output anything. That's why! try outputting something to check if it works (it should).

JBYT27 (1150)

umm, i did. take a look at both files and the last statement in main.py @Bookie0

Bookie0 (4977)

@JBYT27 think it's because on line 28, you have this while true statement, so it keeps on going, with no break statement to stop it

Bookie0 (4977)

since the while true loop is before when you call the function webpage(), then it'll never proceed @JBYT27

JBYT27 (1150)
  1. ok, ill try that
  2. how do you type so fast?!?
    @Bookie0
Bookie0 (4977)

@JBYT27 Mostly because I just do, and I have a great MacBook air with a super keyboard lol

Bookie0 (4977)

@JBYT27 also lemme know if it works! :)

JBYT27 (1150)

btw, it works! hooray! ill mark you @Bookie0

Bookie0 (4977)

wooh! glad it works! :D @JBYT27

RYANTADIPARTHI (3231)

Try forking, or new repl

Try forking, or making a new repl, if it still doesn't work, just report this to bugs. click here

JBYT27 (1150)

ok, thx. And yeah, I tried the forking and new repl, doesn't work. I'll report it to bugs! @RYANTADIPARTHI

JBYT27 (1150)

uhh, maybe after I check PattanAhmed's way first. He did answer my question first. He told me to keep him updated, i'll see if it works first. If it doesn't, ill mark you @RYANTADIPARTHI

JBYT27 (1150)

i tried bookie0's way, and it worked. i cant mark you, but ill upvote you ;) @RYANTADIPARTHI

PattanAhmed (1359)

@JBYT27 Hi,
I have faced this problem four times in a row!

I don't know what is with Repl.it but I just forked the Repl and the console goes fine again.

So, Try to fork and check it out.
Keep me updated!

Thanks!
Hope this helps!

JBYT27 (1150)

ok, thx! i'll try it out!
Edit: I can't fork? @PattanAhmed

PattanAhmed (1359)

@JBYT27 Welcome!
Wait, you can't fork?

Click this button:-

JBYT27 (1150)

oh! LOL, nevermind, yeah, i'll try that @PattanAhmed

PattanAhmed (1359)

@JBYT27 yeah, lol!
Try and keep me updated :)

JBYT27 (1150)

ok, and
UPDATE1: Nope, doesn't work... lol
@PattanAhmed

JBYT27 (1150)

im trying somethin, wait a sec @PattanAhmed

JBYT27 (1150)

i tried bookie0's way, and it worked. i cant mark you, but ill upvote you ;) @PattanAhmed

PattanAhmed (1359)

@JBYT27 WoW, Glad it works fine.

I was looking from Repl.it side, I didn't check the code, lol

Bookie0 (4977)

report to bugs here

try to reload/refresh/delete tab. You can always try to fork the repl. Or make a new repl, and see if the problem persists there as well.

JBYT27 (1150)

I did all of that ;) @Bookie0