Ask coding questions

← Back to all posts
can't install html5-parser
mIcHyAmRaNe (0)

Repl.it: Installing fresh packages

Collecting html5_parser
  Downloading https://files.pythonhosted.org/packages/6a/04/f7d0503d66ec594b716a291bc911a5392c20a3c5966db823e62f9887e955/html5-parser-0.4.6.tar.gz (275kB)
    ERROR: Complete output from command python setup.py egg_info:
    ERROR: pkg-config is required to build html5-parser
    ----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in/tmp/pip-install-maqzvotz/html5-parser/
Commentshotnewtop
niorg2606 (59)

How did you install it? Did you do a manual installation or did you choose html5-parser from the packages list?

mIcHyAmRaNe (0)

@niorg2606
when we import a module , it install it automatically when running the script
but when importing html5_parser i got that error,

i tried also with manual mode: open shell and pip3 install --user html5_parser but got same error

niorg2606 (59)

@mIcHyAmRaNe I don't normally code in Python, but it looks like you need something called PkgConfig, which you can install using pip install pkgconfig.