Have a problem with only this IDE.
thongth (0)

This program works very well on another site but it keep failing when I tried to run it on this site. (it doesn't print out the result in line 2 in the given picture) Is there any reasons to this?
You can try it yourself if you want to.
Ps. The picture shows how I want the program to be. (And it was on another site)

You are viewing a single comment. View All
JoshDaBosh (78)

@thongth change the last 2 lines to just this:
print(*lisR, sep=" ")

thongth (0)

@JoshDaBosh Wow, It really works. Do you have any idea why it didn't print anything at first whilst others did.

JoshDaBosh (78)

@thongth it's something to do with the end=" " and how repl.it handles it. (I was super confused as well lol)
The "*" in my line is just python "shorthand" for all elements in that list. I've tried using end="\n" and sep=" " in your original code's last line and it works.
Repl.it is funny sometimes :\

amasad (2269)

@JoshDaBosh Sorry about that. It shouldn't be funny at all. We'll fix it today. Let us know here or email me directly if anything is ever funny [email protected] (I'm the ceo)