Share your repls and programming experiences

← Back to all posts
AILEE: Artificial Intelligence Lionux Exploit Environment
grantHaataja (4)

Hello Everyone!

Thanks for taking the time to play our game. ( @mishaturnbull and @DavidWilson )

This game is a penetration-testing simulator where you play as an Artificial Intelligence named Ailee who is being trained to hack systems and find security flaws.

There is much tension between some of the people involved with the development of this AI. Will the experiment be a success, or cause massive chaos and destruction upon the financial world?

Features a custom built emulator for a Linux-style terminal. Use classic Unix commands, as well as some of our own.

Remember to follow the administrator's instructions, and if you ever get stuck, a log of your conversations will be saved in AILEE's filesystem.

Click Here to play the game

Here is the source, view at your leisure

Commentshotnewtop
timmy_i_chen (952)

We really liked the intro screen :D

DavidWilson (4)

@timmy_i_chen Thanks! Learning the curses library made it a lot easier

mishaturnbull (4)

Plenty of easter eggs to find.

DavidWilson (4)

@mishaturnbull Did you say multiple endings?

xXRealFuserXx (2)

WOAHHH!!!!!! Awesome Game! One question... When that transfer happened, who did it get transfered to?

grantHaataja (4)

@xXRealFuserXx
Thanks! An "unknown account". Something that could be explained if we decide to develop this demo into a full-fledged game :)

cat_optimist (3)

I think I just became a gnome...

DavidWilson (4)

@cat_optimist Don't know what you are talking about. There are no gnomes in our game....

AkhilGupta (16)

My game ended unexpectedly :(

I want to finish the game. Can you look into it, and may be provide the fixed version in a different repl (as you probably should not edit the one in submission)
Loved the descriptions of the commands! Gnome 😅

Not sure if it helps, but I read the manual for each command, before proceeding with the game. Once done, I used right click to copy paste a lot of stuff, starting with adding the email address, then "pscan" and then "vscan". I believe I also made a few spelling mistakes at various stages, though I doubt they caused the sudden exit from the game.

Maybe I'll try it again.

AkhilGupta (16)

@AkhilGupta Tried again, no issues this time. Finished this great game. :)

grantHaataja (4)

@AkhilGupta Yeah this issue has happened before, but our best guess is that it's a problem with Repl. Nothing you did should have caused that. Glad you liked it! :)

AkhilGupta (16)

@grantHaataja I think I might know what the issue is! Since it happened again a few times, while I was tries to see if there are other hidden endings or something!

I believe it happens if you leave the terminal alone (no interaction) for a few minutes! I am not 100% sure, but it happened again, twice, and each time I had to go afk for a few minutes, only to find that the repl had finished executing when I came back!

Probably a repl staff can better clarify this!

Also, in case this is indeed the case, then shortening the intro/allowing to skip it will really help, since it serves little purpose in the 2nd play through, and is very long. In fact one of the times I switched to another tab while waiting for the intro to end, yes, that too!

Well, can you let me know if there are multiple ending?

grantHaataja (4)

@AkhilGupta You can press Ctrl+C while the text is displaying to cut off the dialogue instead of waiting for it.

Yes, we have 3 endings for the game so far. :-}

AkhilGupta (16)

@grantHaataja oh wow... Now I'll have keep searching I guess!

And I think repl doesn't do well with ctrl+C; it break the UI a little, sloping that ASCII Art...but guess it will work! No worries though! :)

grantHaataja (4)

@AkhilGupta Don't do it during the intro screen. Just when the blue dialogue is running.

AkhilGupta (16)

@grantHaataja Yeah, tried that, still breaks the UI a little. No worries, I'll just let the intro play out normally, it's not a big deal!

LoganTorgerson (1)

So which of you represent the slackers Erin and Mario??!

DavidWilson (4)

@LoganTorgerson First, congrats on your find! :D

Well @mishaturnbull wrote the exploit command, and @grantHaataja has an affinity for gnomes....