Share your repls and programming experiences

← Back to all posts
🔥Minecraft Server on Repl.it!🔥
h
Scoder12 (771)

How to run a minecraft server on repl.it

Hey guys today I'm going to show you how to run a minecraft server on repl.it.

Note: You need hacker plan for this to work right now!

Installation is super simple!

  1. Start a new bash repl
  2. In the console paste this:
wget -O mc.sh https://xpiredl.scoder12.repl.co/mc.sh
  1. In main.sh, paste this:
bash mc.sh

Run the repl and follow the instructions!
Once you see Done! in the console, connect to the ip shown in ip.txt
If you have questions ask in the comments!

How to change minecraft version

  1. If you already have a server, delete the files mc/server.jar and mc.sh
  2. Run the command above that starts with wget again (even if you already have the script)
  3. In mc.sh, find the line that says VERSION=1.16.3 and edit it to your desired version

Huge shoutout to @letsrepl for the initial concept.

Remember to upvote if you enjoyed!

Commentshotnewtop
Onetopic (5)

excited villager noises

gg2001 (2)

Consider putting php -S 0.0.0.0:3000 ip.txt & bash mc.sh in main.sh, instead of just bash mc.sh. This automatically sets up a website for it, making it easier to use with uptime robot.

Once this is setup, go to uptime robot and create a keyword monitor that checks every 5 minutes for the keywords "Server running on". That way the server will stay up all the time.

Don't forget to put the ngrok_token and ngrok_region values in your .env!

zhidao (13)

I actually made a server!!! You have to make a .env file beforehand and it will work!

zhidao (13)

@zhidao

and plus, I have Minecraft

ThomasHagan (2)

how did you make the .env file? @zhidao

zhidao (13)

@ThomasHagan

bruh

just make a .env file named .env and put ur ngrok token inside

ThomasHagan (2)

@zhidao I tried that. I'll start again and create the .env file first as you mentioned. I was thinking there was something in the naming I may have been missing. Thanks!

zhidao (13)

@ThomasHagan no the .env file is lit named ".env"

ThomasHagan (2)

@zhidao Thanks! Felt a bit dumb to find that out.

Coder100 (12448)

ree not work here

basically whats the ngrok key reee

Scoder12 (771)

@Coder100 You have to login to the dashboard that it gives you, and then copy the auth token

Coder100 (12448)

ok what do i log in with i don't want to make acc reee @Scoder12

yadunandanrocks (1)

When is the minecraft Bedrock server coming out? I can help you test it if required

santacountdown (0)

@yadunandanrocks i also want a minecraft bedrock server on repl

Scoder12 (771)

@yadunandanrocks not sure, I don't know how to set it up tbh

DiveshTheReal (76)

i just create the server and got this Can't keep up! Is the server overloaded? :/

PokeGirl1024 (2)

Can you do this without Hacker? I'm a random kid wanting to play Minecraft and I've already used my savings for that.

DarshanRajpara1 (13)

Does it work for bedrock too?

tussiez (537)

@DarshanRajpara1 If you could find low-level access to the Linux host of the Repl servers, yes. I'm still not sure if you can. With third-party hosts like PocketMine that runs on PHP, I bet you could.

Scoder12 (771)

@DarshanRajpara1 Someone was asking for help with a bedrock server using pocketmine, but they were having trouble connecting. I think thats its definitely possible in theory but hasn't been pulled off yet

CroxyTheDev (0)

it says "chmod: cannot access 'jre/bin/java': No such file or directory" please help me dude

Scoder12 (771)

@CroxyTheDev sorry, should be fixed now if you try again

ByGoneNeutron (0)

chmod: cannot access 'jre/bin/java': No such file or directory
exit status 1

please help

Scoder12 (771)

@ByGoneNeutron delete repl and try again. If you are concerned about losing your world, delete mc.sh and re-download it

ByGoneNeutron (0)

dont have a world yet D: @Scoder12

Scoder12 (771)

@ByGoneNeutron then delete the repl and try again, it was a bug in the script so dw its not your fault

DemonKingSwarn1 (0)

i got an "unknown host" error inside minecraft.
Also how to update the server to latest minecraft version.

Scoder12 (771)

@DemonKingSwarn1 Are you connecting to the ip that is in ip.txt after it says "Ready" in the console? and check the post, I updated it with instructions on how to update to latest version

927gaming (0)

how can I upgrade the server version?
it says outdated server i'm still on 1.15.1

Scoder12 (771)

@927gaming Delete the repl and try again, should work now

AcceleratedCode (37)

I got a SSL error "Unable to establish SSL connection." in wget. using Curl got me curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to xpiredl.scoder12.repl.co:443

Scoder12 (771)

@AcceleratedCode Hi, replit is experience issues with all server repls lately, so you'll have to manually copy and paste the script from the repl I linked to the post.

EpicBoomerMomen (0)

Hey, first of all thank you for the helpful tip! Can you upload an existing world onto the server?

Scoder12 (771)

@EpicBoomerMomen Yep, you can, once you run the script for the first time it should create the traditional server file structure. Then you can stop the server and replace the world .dat files by uploading into the repl. Only thing to keep in mind is that there is a size limit per repl that cannot be increased.

willuhmjs (12)

coder dm me on discord. is it possible you and i can work on doing this but for SCP:SL servers instead?

AyoX2 (1)

It says the server is overloaded and cant keep up

AphixDev (204)

aish, I'm a bash noob. How do u do the .env stuff?

athenaluo (34)

Do we have to download Xpire?

RossJames (305)

ngrok.com does not load

Scoder12 (771)

@RossJames weird, I don't know how to fix

gg2001 (2)
chmod: changing permissions of 'jre/bin/java': Disk quota exceeded
exit status 1```


It seems to have stopped working.
Scoder12 (771)

@gg2001 exactly what it says: disk quota exceeded. Try a new repl, don't load as many chunks next time

nahu (27)

I dont know bash

nahu (27)

It deos not work do u know to to fix it

Scoder12 (771)

@nahu you have to give more information than that.

nahu (27)

i dont no where the console [email protected]

iPenguin (7)

i can't connect - i keep getting io.netty.channel.abstractchannel$annotatedconnectexceptioon: connection timed out

Scoder12 (771)

@iPenguin weird, what does your IP look like?

iPenguin (7)

@Scoder12 here's an example one: 0.tcp.ngrok.io:12679

Scoder12 (771)

@iPenguin thats completely expected. Are you sure you waited until the server printed out Done! and your internet is fine?

iPenguin (7)

@Scoder12 yeah. i thought it might have been something i messed with in server files, so i tried recreating the server a few times in a new completely new repl but with the same results

iPenguin (7)

@Scoder12 also, the server console never logs that i attempted to join and the motd never appears in the server list

Scoder12 (771)

@iPenguin share the repl with me maybe I can help

Scoder12 (771)

@iPenguin Try running it again, make sure that it prints out "Done" before you join

iPenguin (7)

@Scoder12 just did, doesnt work for me. i could try to get one of my friends to join later today and see if it works for them

MatthewDoan1 (331)

Could you explain what this does?

(by the way everyone, I'm BACK!!!)

iPenguin (7)

Is there a way to use a dedicated IP?

Scoder12 (771)

@iPenguin yeah, pay for ngrok pro plan or use some sort of dynamic dns

APCSPShehadaK (0)

Hey, any way to keep the server alive? The server closes very quickly even with hacker plan, I even lost ~5min of progress (autosave).
I wasn't able to listen to port 8080 & host the mc server at the same time as the http server would close as soon as the mc server started.

Any suggestions or plans?

Unrelated: Inside of your server.properties, I'd recommend setting sync-chunk-writes=false to improve performance & enable-rcon=false as rcon is not being used.

Scoder12 (771)

@APCSPShehadaK its very tricky to have multiple ports listening on repl.it and have the correct one be forwarded but you might be able to get it to work.

APCSPShehadaK (0)

@Scoder12
Solved with a vanilla php server on port 3000.
index.html is a placeholder, the file can hold anything but should exist.

main.sh:
php -S 0.0.0.0:3000 index.html & bash mc.sh

[deleted]

Java or Bedrock? (Not that I want to do it, I just want to find out) Im pretty sure its Java. :(

Scoder12 (771)

@CarlosRosiles yep java. Bedrock server might happen, stay tuned...

[deleted]
dm89263 (0)

where is the console?

QuintenBuwalda (0)

@dm89263 The console is the normal console you have on the side of your IDE.