Share your repls and programming experiences

← Back to all posts
Minecraft on Replit
h
SPQR (453)

need I say more?
.
DISCLAIMER: It's a pain to log in and it's essentially unplayable due to the controls not working, but it actually runs ok on minimum settings. Hopefully future updates to the gfx here will allow it to work properly :))

EDIT: Yes, I know that shift doesn't work, and that you can't copy and paste your email in. Maybe try forking?

EDIT EDIT: it's for servers now cuz i accidentally redid the entire thing without forking
the original is here: https://repl.it/@SPQR/Minecraft

Commentshotnewtop
randomlylelo (27)

took a solid 2 minutes to load, but the results are... beautiful

jamiebally (4)

The copy-paste file doesn't work. I have tried typing the last makefile line in but it still doesn't do anything.
I can right click and click the paste button, but nothing appears.

ebest (590)

Senātus Populusque Rōmānus!

bonnym512 (86)

@ebest Why Did you say SPQR? That was a Roman Phrase?

ebest (590)

@bonnym512 Yes. SPQR = Senātus Populusque Rōmānus!

bonnym512 (86)

@ebest I know, but you aren't Senatus Populusque Romanus. that is the creator of this.

lsambrook (286)

Hey I made a website, please go check it out and tell me some suggestions, ideas, or things to improve.: https://repl.it/@lsambrook/Website-2

AdCharity (207)

@lsambrook ngl I think you tooke the whole styling scheme from w3 schools

Zavexeon (667)

SPQR is the port master lol.

SPQR (453)

@Zavexeon LMAO im putting that in my bio

CollinKunsman (96)

When I try creating an account, it doesn't let me use the @ symbol.

ETHANSIAO (33)

I'd love to play this, but I'm not able to use the @ sign for my login. Is it possible to fix this?

SPQR (453)

@ETHANSIAO paste it into logins.txt, then paste it into the email field using right click (ctrl+v doesn't work) You'll also need to do it for any capital letters. If you want to have multiple things pasted, copy and paste the last line of the makefile into the replit shell (accessible using f1> open shell, or right click edit window > open shell) any time you update logins.txt

CullenDAvello (18)

@SPQR caps lock works for capitals but not special characters

ETHANSIAO (33)

@SPQR I'm still unable to use the @ sign at the moment, could you please share a screenshot with me about how to properly add special characters to login.txt?

minermaniac447 (192)

Wanted to try this out... but is there any way to have the logins file be replaced with a .env file? I don't really want all of replit to know my minecraft login, and I can't modify it because I don't really know how you're doing the login.

SPQR (453)

@minermaniac447 i dunno how to do that tbh, but what i did is only put the special symbols and caps in logins.txt, then pasted it and edited where necessary

amasad (1752)

@SPQR what bugs do we need to fix to make this better in the future?

SPQR (453)

@amasad Well, the main issue i noticed is a discrepancy with controls. I noticed that the issue I'm experiencing somewhat reminds me of an issue I would see if using a touchscreen. No matter how I move the mouse, the game seems to interpret it as moving towards the bottom right corner of the screen. The only cause for that that I could think of would be that the frontend sends mouse position to X incorrectly, i.e. instead of X seeing that the mouse moved in a certain direction, it only sees that the mouse sort of teleported somewhere that i would assume is down and to the right of the crosshair. Also, The keyboard input is working very strangely in that Minecraft only seems to recognize about 1 of every 10 key presses (For comparison, when I ran DOOM, it recognized pretty much all of them.) I also noticed that X (or at least Minecraft) seems to think that Right Alt is being constantly held down (i noticed this when i tried to rebind one of the controls to the L key and it instead bound to Right Alt.) Other than that, there's really just the QOL improvements of easier interaction with the clipboard in the X window, and/or somehow getting the SHIFT key to work (I can't type caps or symbols, hence why i need copy and paste)

I dont want to seem like i'm ragging on replit though, because frankly, I didn't even expect this to work at all, so just being able to get it to run is pretty awesome. :)

HarperframeInc (240)

@amasad Also, can you make GFX work for repl.run

SPQR (453)

@HarperframeInc I'd imagine they're working on it

duck132912 (47)

Does this actually run minecraft?

SPQR (453)

@duck132912 it used to, but i broke it :P

SPQR (453)

@duck132912 I can if you'd like, but don't get the idea that you'll be playing Minecraft on repl.it anytime soon. Due to the interface between the browser and repl.it servers, the game is entirely unplayable (the mouse doesn't act like it should, it's like playing PC minecraft with a touchscreen if you've ever done that.)

But I'm a nice guy if you really want to see it for yourself i can do it. :)

duck132912 (47)

@SPQR oh that bug, so the mouse pointer does not lock?

SPQR (453)

@duck132912 Nope. Unfortunately I don't think there's any way to make it lock, because I don't think webpages are capable of capturing the mouse like that

TheImagin33r (21)

im scared for when it finishes loading. im using a chromebook XD

yanovsky (1)

Still preparing spawn area, at 0%

yanovsky (1)

Mine took forever to load, and is still not loding

yanovsky (1)

Why is this so slow?

SPQR (453)

@yanovsky B/C it's running on a virtual machine which you are accessing remotely

AidenWaterman (0)

the link to the original is a 404, here the original:
https://repl.it/@SPQR/Minecraft-on-Replit-2-Boogaloo
It is missing export DISPLAY=:0.0 so here is a fixed one
https://repl.it/@AidenWaterman/Minecraft-on-Replit-2-Boogaloo

ebest (590)

@SPQR, Can you "PLEASE " 1000000 delete your Firefox browser because a lot of people in my school are using it and I "REALLY " 1000000^10000000000000000 (overflow error) don't want repl.it blocked. PLEASE?

-Ebest

SPQR (453)

@ebest no problem, I know how it feels to be in that situation

ebest (590)

@SPQR my mistake of telling other people about it. If only you replaced it with some message like "Gah! Firefox has crashed."

GameMaster1928 (41)

It stopped working today

locness3 (13)

What type of repl did you choose ?

kamalhasan (6)

took around 5 minutes to load but it was amazing.
cant copy tho.

RobertoBean (28)

...this does put a smile on my face

KiKUP (42)

Wow, I got Preparing Spawn Area: 0% about 200 times before it actually started loading. Amazing game, nonetheless!

JacobHonaker (0)

Game Crashes no matter what. I just waited 9 minutes and it showed that it was opening, but then it went back to launcher

HarperframeInc (240)

Can't insert @ in the email field

SPQR (453)

@HarperframeInc try forking the repl and use right click > paste to paste the contents of the .txt file

NathanWassem (0)

@triptych What is that? I hope it is a mouse driver because minecraft on replit needs a mouse fix.

triptych (3)

@NathanWassem Godot is a GUI game development app that is FOSS and highly cross platform. https://godotengine.org/ Having a remote version of this running would be a huge boon to indie game developers and hobbyists.

ABulman (7)

REEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE

MarkelL (10)

Bro this is so cool, keep up and make it functional!

ZacharyWood (28)

Doesn't let me use the '@' character when I enter my e-mail. :,(

GameMaster1928 (41)

Help I can't type the @ symbol to sign in

The text from logins.txt isn't copied to the clipboard.

SPQR (453)

@GameMaster1928 paste the last line of the makefile into the shell and press enter and it should do it

NathanWassem (0)

@GameMaster1928 You have to put the last line in while running and then paste it in there

GameMaster1928 (41)

@NathanWassem
Yes I did that

I'll just try again

GameMaster1928 (41)

@SPQR
It gives me this error when I copy and paste into the console:

NathanWassem (0)

@GameMaster1928
Even if you do manage to login, its not really that good. There are lots of bugs that need to be fixed like mouse input, key input, and more importantly, shift. If this project gets developed and updated more, then maybe minecraft java edition could also be for chromebooks too.

NathanWassem (0)

@GameMaster1928 right click your @ symbol in logins.txt and type "open shell". while running. then paste the last line, not into the console, but in the shell.

SPQR (453)

@GameMaster1928 right click on code, command palette, type "open shell" and press enter

ProgrammerAI (4)

what language is this?

SPQR (453)

@ProgrammerAI It uses makefile syntax (It's more or less Bash)