SceneMachine: Drag, configure and shoot! (SVG 2D Physics Game)
ggzor (35)


Hi! Welcome to my game! This is a 2D physics game made with SVG graphics.

Play now! (Play in fullscreen mode for a better experience)

Note: This game has been extensively tested on Chrome. I recommend you playing with Chrome as it offers the best experience. It works on desktop only.


Your goal is to find out what has happened to the colors of the planet, New Sphene, and to do that, you have to explore from the deserts of the planet down to its core.

You are not alone in this journey, there is a group of brave volunteers willing to help you. All you have to do is instruct them on how to collaborate together and let them combine their skills to achieve your goals.

Game features

  • 9 exciting and challenging levels.
  • In-game tips, right when you need them.
  • Achievements and special challenges per level.
  • Polished user interaction.
  • Intuitive and easy to use level camera.
  • (Simple) Level cinematics.
  • Progress saving.
  • Hard worked user interface.
  • Animations.


This game was completely coded by me here on the editor. Art and level design was made by @k3ho45. Full credits can be found inside the game. Enjoy!

Additional notes

  • I really hope you enjoy this game, as much as I enjoyed coding it. I have put a lot of effort to make this game a great experience.
  • Sorry for my English™, if you find any typo, please let me know.
  • I would love to hear your comments!

Known issues

  • When performing tests on multiple web browsers and different machines, in very few occasions (extremely rare) the graphics didn't show correctly. Please switch to another browser if you experiment this issue.
You are viewing a single comment. View All
ggzor (35)

@ebest I'm sorry for the inconvenience. Could you share me your browser version? I think it could be a browser compatibility issue.

ebest (617)

@ggzor could you try to see if there is an error?

My browser is the newest version of chrome though

ggzor (35)

@ebest Thanks for your feedback. The Store script was executing before the Vuex library loaded. It should be working now. Please let me know if you find any other issue.

ebest (617)

@ggzor Thanks!!!!!


Still does not work. Vuex does not exist.

ggzor (35)

@ebest Could you check if it's working now, please? I have switched to other CDN for the Vuex library.

ebest (617)

@ggzor It works now!!!